MEPModelGetAssignedElectricalSystems Method |
Retrieves the electrical systems this electrical panel currently is assigned to.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElectricalSystem> GetAssignedElectricalSystems()
Public Function GetAssignedElectricalSystems As ISet(Of ElectricalSystem)
public:
ISet<ElectricalSystem^>^ GetAssignedElectricalSystems()
member GetAssignedElectricalSystems : unit -> ISet<ElectricalSystem>
Return Value
ISetElectricalSystem
Remarks
This property returns a set of Electrical Systems. If there are no electrical systems created
for this model, this property will be an empty set.
This method supersedes an older AssignedElectricalSystems property which has been deprecated.
See Also