ElectricalEquipmentMaxNumberOfCircuits Property |
The maximum number of circuits for switchboard.
The quantity of circuits can be assigned to switchboard through breaker.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int MaxNumberOfCircuits { get; set; }
Public Property MaxNumberOfCircuits As Integer
Get
Set
public:
property int MaxNumberOfCircuits {
int get ();
void set (int value);
}
member MaxNumberOfCircuits : int with get, set
Property Value
Int32
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The input max number of circuits value is invalid for switchboard.
|
InvalidOperationException |
The electrical equipment is not a switchboard equipment.
|
See Also