SelectionUIOptions Class

Provides access to user settings related to how selection will behave in Revit's UI.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UISelectionUIOptions

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SelectionUIOptions : IDisposable

The SelectionUIOptions type exposes the following members.

Properties
 NameDescription
Public propertyActivateControlsAndDimensionsOnMultiSelect Indicates whether controls and temporary dimensions are activated on selection of multiple elements.
Public propertyDragOnSelection Indicates whether elements can be dragged immediately when they are selected.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySelectFaces Indicates whether elements can be selected by clicking on the interior of a face.
Public propertySelectLinks Indicates whether Revit and CAD link instances can be selected.
Public propertySelectPinned Indicates whether pinned elements can be selected.
Public propertySelectUnderlay Indicates whether elements that are displayed as underlay can be selected.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SelectionUIOptions
Public methodStatic memberElementSelectsAsPinned Checks whether the specified element will be treated as pinned for the purposes of selection.
Public methodStatic memberGetSelectionUIOptions Returns the current user's SelectionOptions.
Top
Remarks
The settings in this class define how selection will behave when the user is selecting one or more elements in a graphical view. These settings do not affect programmatic selection behavior. Some UI commands may override the user's settings while the command is active.

These settings are per user and will affect the selection behavior in all projects and families. The settings are not stored in the project.

See Also