SelectionUIOptionsElementSelectsAsPinned Method |
Checks whether the specified element will be treated as pinned for the purposes of selection.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ElementSelectsAsPinned(
Document document,
Element element
)
Public Shared Function ElementSelectsAsPinned (
document As Document,
element As Element
) As Boolean
public:
static bool ElementSelectsAsPinned(
Document^ document,
Element^ element
)
static member ElementSelectsAsPinned :
document : Document *
element : Element -> bool
Parameters
- document Document
-
The document containing the element.
- element Element
-
The element to check.
Return Value
Boolean
True if the specified element should be treated as pinned for selection purposes, false otherwise.
Exceptions
Remarks
To improve usability, the option to disable pinned selection has some additional intelligence
beyond simply checking the pinned status. For example, if a model group is pinned, the corresponding
attached detail group will also be treated as pinned for the purposes of selection. If this method
returns true, the specified element will not be selectable when selection of pinned elements is
disabled.
See Also