SelectionUIOptionsDragOnSelection Property |
Indicates whether elements can be dragged immediately when they are selected.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool DragOnSelection { get; set; }
Public Property DragOnSelection As Boolean
Get
Set
public:
property bool DragOnSelection {
bool get ();
void set (bool value);
}
member DragOnSelection : bool with get, set
Property Value
Boolean
Remarks
When this setting is false, the user must click once to select an element and then must
explicitly click again in order to drag the element. This option helps users avoid accidentally
moving elements. When this setting is true, the user can click on an element to select it
and drag the element immediately by holding down the mouse.
See Also