SelectionUIOptionsActivateControlsAndDimensionsOnMultiSelect Property |
Indicates whether controls and temporary dimensions are activated on selection of multiple elements.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool ActivateControlsAndDimensionsOnMultiSelect { get; set; }
Public Property ActivateControlsAndDimensionsOnMultiSelect As Boolean
Get
Set
public:
property bool ActivateControlsAndDimensionsOnMultiSelect {
bool get ();
void set (bool value);
}
member ActivateControlsAndDimensionsOnMultiSelect : bool with get, set
Property Value
Boolean
Remarks
Revit always shows certain controls and temporary dimensions for a single selected element
When this option is set Revit also shows these controls and dimensions when multiple elements are selected.
Note that this setting takes effect on the next selection change.
To have this change take effect immediately use
Selection.SetElementIds(Selection.GetElementIds());
See Also