SelectionUIOptionsSelectPinned Property |
Indicates whether pinned elements can be selected.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool SelectPinned { get; set; }
Public Property SelectPinned As Boolean
Get
Set
public:
property bool SelectPinned {
bool get ();
void set (bool value);
}
member SelectPinned : bool with get, set
Property Value
Boolean
Remarks
When this setting is false, the user cannot select most pinned elements in canvas. This option
helps users avoid accidentally moving important pinned objects such as levels and grids. When
this option is true, the user can select pinned elements directly.
Note that to improve usability, the behavior of this option has some added intelligence
beyond simply checking whether the element is pinned. For example, if a model group is pinned,
the corresponding attached detail group is not selectable if selection of pinned elements is
disabled. To check whether a particular element is pinned for purposes of this setting, see
ElementSelectsAsPinned(Document, Element).
See Also