RuledSurface Class

A ruled surface is created by sweeping a line between two profile curves or between a curve and a point (a point and a curve). Input curve(s) must be bounded or have natural bounds.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBRuledSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RuledSurface : Surface

The RuledSurface type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodStatic memberCreate(Curve, Curve) Creates a Surface object coincident with the ruled surface joining two bounded generating curves.
Public methodStatic memberCreate(Curve, XYZ) Creates a Surface object coincident with the ruled surface joining a bounded generating curve to a point.
Public methodGetFirstProfileCurve Returns a copy of the first profile curve if it is set.
Public methodGetFirstProfilePoint If a point was used to define the first profile, returns a copy of that point.
Public methodGetSecondProfileCurve Returns a copy of the second profile curve if it is set.
Public methodGetSecondProfilePoint If a point was used to define the second profile, returns a copy of that point.
Public methodHasFirstProfilePoint Checks if a point was used to define the first profile.
Public methodHasSecondProfilePoint Checks if a point was used to define the second profile.
Top
Remarks
Both curves are evaluated in normalized parameters [0, 1] The parametric equations of a ruled surface are:
  • Curve C1 and curve C2 : S(u, v) = C1(u) + v * (C2(u) - C1(u));
  • Point P1 and curve C2 : S(u, v) = P1 + v * (C2(u) - P1);
  • Curve C1 and point P2 : S(u, v) = C1(u) + v * (P2 - C1(u));
The point/point case is not allowed as that would define a degenerate ruled surface.
See Also