SurfaceProjectWithGuessPoint Method |
Project a 3D point orthogonally onto a surface (to find the nearest point).
This method is meant to be used when a good approximate solution for the projection is available.
Throws InvalidOperationException if the projection fails.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ProjectWithGuessPoint(
XYZ point,
UV guessUV,
out UV uv,
out double distance
)
Public Sub ProjectWithGuessPoint (
point As XYZ,
guessUV As UV,
<OutAttribute> ByRef uv As UV,
<OutAttribute> ByRef distance As Double
)
public:
void ProjectWithGuessPoint(
XYZ^ point,
UV^ guessUV,
[OutAttribute] UV^% uv,
[OutAttribute] double% distance
)
member ProjectWithGuessPoint :
point : XYZ *
guessUV : UV *
uv : UV byref *
distance : float byref -> unit
Parameters
- point XYZ
-
The point to project.
- guessUV UV
-
The calculation will look for a project near the provided UV.
- uv UV
-
The surface coordinates of the projected point.
- distance Double
-
Holds the distance from input point to its projection.
Exceptions
See Also