Project a 3D point orthogonally onto a surface (to find the nearest point).
Throws InvalidOperationException if the projection fails.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Project(
XYZ point,
out UV uv,
out double distance
)
Public Sub Project (
point As XYZ,
<OutAttribute> ByRef uv As UV,
<OutAttribute> ByRef distance As Double
)
public:
void Project(
XYZ^ point,
[OutAttribute] UV^% uv,
[OutAttribute] double% distance
)
member Project :
point : XYZ *
uv : UV byref *
distance : float byref -> unit
Parameters
- point XYZ
-
The point to project.
- uv UV
-
The surface coordinates of the projected point.
- distance Double
-
Holds the distance from input point to its projection.
Exceptions
See Also