ComboBoxMember Class

This class represents an item in the drop-down list of a ComboBox.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIRibbonItem
    Autodesk.Revit.UIComboBoxMember

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ComboBoxMember : RibbonItem

The ComboBoxMember type exposes the following members.

Properties
 NameDescription
Public propertyEnabledGets or sets a value indicating whether the item is enabled.
(Inherited from RibbonItem)
Public propertyGroupNameThe group to which the ComboBoxMember is assigned.
Public propertyImageThe image shown on the ComboBoxMember.
Public propertyItemTextGets or sets the text displayed on the item.
(Inherited from RibbonItem)
Public propertyItemTypeGets the item type.
(Inherited from RibbonItem)
Public propertyLongDescription Long description of the command tooltip
(Inherited from RibbonItem)
Public propertyNameThe name of the item.
(Inherited from RibbonItem)
Public propertyToolTipThe description that appears as a ToolTip for the item.
(Inherited from RibbonItem)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
(Inherited from RibbonItem)
Public propertyVisibleGets or sets a value indicating whether the item is visible.
(Inherited from RibbonItem)
Top
Methods
 NameDescription
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from RibbonItem)
Public methodGetContextualHelpGets the contextual help bound with this control.
(Inherited from RibbonItem)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button.
(Inherited from RibbonItem)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Note that a ComboBoxMember will not show an individual tool tip. Use of this class is not supported in Revit Macros.
See Also