IFCFileGetInstanceCount Method |
Counts IFC instances of one particular type.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic int GetInstanceCount(
string entityName,
bool includeSubTypes
)
Public Function GetInstanceCount (
entityName As String,
includeSubTypes As Boolean
) As Integer
public:
int GetInstanceCount(
String^ entityName,
bool includeSubTypes
)
member GetInstanceCount :
entityName : string *
includeSubTypes : bool -> int
Parameters
- entityName String
-
The name of the instance type.
- includeSubTypes Boolean
-
True to count instances of sub types.
Return Value
Int32
The count.
Exceptions
See Also