IFCFileCreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) Method |
Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle,
and assigns them to the file.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCAnyHandle CreateStyle(
ExporterIFC exporterIFC,
IFCAnyHandle repItem,
Color color,
ElementId fillPatternId
)
Public Function CreateStyle (
exporterIFC As ExporterIFC,
repItem As IFCAnyHandle,
color As Color,
fillPatternId As ElementId
) As IFCAnyHandle
public:
IFCAnyHandle^ CreateStyle(
ExporterIFC^ exporterIFC,
IFCAnyHandle^ repItem,
Color^ color,
ElementId^ fillPatternId
)
member CreateStyle :
exporterIFC : ExporterIFC *
repItem : IFCAnyHandle *
color : Color *
fillPatternId : ElementId -> IFCAnyHandle
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- repItem IFCAnyHandle
-
The representation item.
- color Color
-
The color.
- fillPatternId ElementId
-
The fill pattern id.
Return Value
IFCAnyHandle
The handle.
Exceptions
See Also