IFCFileGetInstances Method |
Gets IFC instances of one particular type.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<IFCAnyHandle> GetInstances(
string entityName,
bool includeSubTypes
)
Public Function GetInstances (
entityName As String,
includeSubTypes As Boolean
) As IList(Of IFCAnyHandle)
public:
IList<IFCAnyHandle^>^ GetInstances(
String^ entityName,
bool includeSubTypes
)
member GetInstances :
entityName : string *
includeSubTypes : bool -> IList<IFCAnyHandle>
Parameters
- entityName String
-
The name of the instance type.
- includeSubTypes Boolean
-
True to retrieve instances of sub types.
Return Value
IListIFCAnyHandle
The instance handles.
Exceptions
See Also