IFCFileRead(IFCFileReadOptions, Int32, Int32) Method |
Reads content from a file of IFC format.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Read(
IFCFileReadOptions readOptions,
out int pNumErrors,
out int pNumWarnings
)
Public Sub Read (
readOptions As IFCFileReadOptions,
<OutAttribute> ByRef pNumErrors As Integer,
<OutAttribute> ByRef pNumWarnings As Integer
)
public:
void Read(
IFCFileReadOptions^ readOptions,
[OutAttribute] int% pNumErrors,
[OutAttribute] int% pNumWarnings
)
member Read :
readOptions : IFCFileReadOptions *
pNumErrors : int byref *
pNumWarnings : int byref -> unit
Parameters
- readOptions IFCFileReadOptions
-
The IFC file read options.
- pNumErrors Int32
-
The number of errors reported during the read process. The actual messages will be in the log file.
- pNumWarnings Int32
-
The number of warnings reported during the read process. The actual messages will be in the log file.
Exceptions
See Also