IFCFileCreateStyle(ExporterIFC, IFCAnyHandle) Method |
Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle,
and assigns them to the file.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCAnyHandle CreateStyle(
ExporterIFC exporterIFC,
IFCAnyHandle repItem
)
Public Function CreateStyle (
exporterIFC As ExporterIFC,
repItem As IFCAnyHandle
) As IFCAnyHandle
public:
IFCAnyHandle^ CreateStyle(
ExporterIFC^ exporterIFC,
IFCAnyHandle^ repItem
)
member CreateStyle :
exporterIFC : ExporterIFC *
repItem : IFCAnyHandle -> IFCAnyHandle
Parameters
- exporterIFC ExporterIFC
-
The exporter.
- repItem IFCAnyHandle
-
The representation item.
Return Value
IFCAnyHandle
The handle.
Exceptions
See Also