CompoundStructureLayer Class

Describes a single layer in a CompoundStructure.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBCompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CompoundStructureLayer : IDisposable

The CompoundStructureLayer type exposes the following members.

Constructors
 NameDescription
Public methodCompoundStructureLayer Creates a compound structure layer using default settings.
Public methodCompoundStructureLayer(CompoundStructureLayer) Creates a copy of a compound structure layer.
Public methodCompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) Creates a default compound structure layer based on the given width, function and material element id.
Top
Properties
 NameDescription
Public propertyDeckEmbeddingType Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public propertyDeckProfileId The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public propertyFunction The function of the layer.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLayerCapFlag Identifies if the layer participates in wrapping at end caps and/or inserts.
Public propertyLayerId The id of the layer - note that this may be different from the index in the array of layers in a CompoundStructure.
Public propertyCode exampleMaterialId Id of the material assigned to this layer.
Public propertyWidth Width of the layer.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the CompoundStructureLayer
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also