CompoundStructureLayerDeckEmbeddingType Property

Embedding type for structural deck - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructDeckEmbeddingType DeckEmbeddingType { get; set; }

Property Value

StructDeckEmbeddingType
The default is StructDeckEmbeddingType.Invalid.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also