CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) Constructor |
Creates a default compound structure layer based on the given width, function and material element id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CompoundStructureLayer(
double width,
MaterialFunctionAssignment function,
ElementId materialId
)
Public Sub New (
width As Double,
function As MaterialFunctionAssignment,
materialId As ElementId
)
public:
CompoundStructureLayer(
double width,
MaterialFunctionAssignment function,
ElementId^ materialId
)
new :
width : float *
function : MaterialFunctionAssignment *
materialId : ElementId -> CompoundStructureLayer
Parameters
- width Double
-
The width of the layer.
- function MaterialFunctionAssignment
-
The function of the layer.
- materialId ElementId
-
The material element id of the layer.
Exceptions
See Also