LightingDevice Class

Provides access to the Lighting Device in Autodesk Revit MEP.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      Autodesk.Revit.DB.ElectricalLightingDevice

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LightingDevice : MEPModel

The LightingDevice type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Top
Remarks
The Lighting Device object can only be queried in Autodesk Revit MEP.
See Also