LightingDevice Class

Provides access to the Lighting Device in Autodesk Revit MEP.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      Autodesk.Revit.DB.ElectricalLightingDevice

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LightingDevice : MEPModel

The LightingDevice type exposes the following members.

Properties
 NameDescription
Public propertyConnectorManager Retrieves the Connector Manager from this MEPModel.
(Inherited from MEPModel)
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from MEPModel)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAssignedElectricalSystems Retrieves the electrical systems this electrical panel currently is assigned to.
(Inherited from MEPModel)
Public methodGetElectricalSystems Retrieves the electrical systems that are currently created using this MEPModel.
(Inherited from MEPModel)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The Lighting Device object can only be queried in Autodesk Revit MEP.
See Also