MechanicalFitting Class

A mechanical fitting in the Autodesk Revit MEP product.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBMEPModel
      Autodesk.Revit.DB.MechanicalMechanicalFitting

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MechanicalFitting : MEPModel

The MechanicalFitting type exposes the following members.

Properties
 NameDescription
Public propertyPartTypeThe part type of the mechanical fitting.
Top
Methods
 NameDescription
Top
Remarks
The mechanical fitting is only available in the Autodesk Revit MEP product.
See Also