BaseExportOptions Class

The base class for options used to export DWG, DXF and DGN format files.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBaseExportOptions
    Autodesk.Revit.DBACADExportOptions
    Autodesk.Revit.DBDGNExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BaseExportOptions : IDisposable

The BaseExportOptions type exposes the following members.

Properties
 NameDescription
Public propertyColors Export color mode. Default value is ExportColorMode.IndexColors.
Public propertyHatchPatternsFileName Custom hatch patterns (pat) file name.
Public propertyHideReferencePlane Whether or not to hide reference planes. Default value is false.
Public propertyHideScopeBox Whether or not to hide the scope box. Default value is false.
Public propertyHideUnreferenceViewTags Whether or not to hide unreference view tags. Default value is false.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLayerMapping Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public propertyPreserveCoincidentLines Whether or not to preserve coincident lines. Default value is false.
Public propertyPropOverrides How to export overridden object styles. Default value is PropOverrideMode.ByEntity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the BaseExportOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetExportFontTable Gets font table.
Public methodGetExportLayerTable Gets the layer table.
Public methodGetExportLinetypeTable Gets a copy of the line type table.
Public methodGetExportPatternTable Gets a copy of the pattern table.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodStatic memberGetPredefinedSetupNames Returns a list of names of predefined setups of export options.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetExportFontTable Sets font table to option.
Public methodSetExportLayerTable Sets layer table back to option
Public methodSetExportLinetypeTable Sets the line type table to use during export.
Public methodSetExportPatternTable Sets the pattern table to use during export.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also