RevolvedSurface Class

A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBRevolvedSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevolvedSurface : Surface

The RevolvedSurface type exposes the following members.

Properties
 NameDescription
Public propertyAxis Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface.
Public propertyOrigin Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface.
Public propertyXDir X axis of the local coordinate system associated with this revolved surface.
Public propertyYDir X axis of the local coordinate system associated with this revolved surface.
Top
Methods
 NameDescription
Public methodStatic memberCreate(Frame, Curve) Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve.
Public methodStatic memberCreate(XYZ, XYZ, Curve) Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve.
Public methodStatic memberCreate(Frame, Curve, Double, Double) Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution.
Public methodStatic memberCreate(XYZ, XYZ, Curve, Double, Double) Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution.
Public methodGetProfileCurve Returns a copy of the profile curve expressed in the surface's coordinate system.
Public methodGetProfileCurveInWorldCoordinates Returns a copy of the profile curve expressed in the world coordinate system.
Public methodStatic memberIsValidProfileCurve(Frame, Curve) Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
Public methodStatic memberIsValidProfileCurve(XYZ, XYZ, Curve) Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Top
Remarks
The parametric equation of a surface of revolution is S(u, v) = center + C1(v)*cos(u)*xVec + C1(v)*sin(u)*yVec + C2(v)*zVec, where the profile curve in the SurfRev's xz plane has the parametric equation (C1(t), C2(t)). Note that the direction of X axis may agree or disagree with the chosen orientation of the surface.
See Also