RevolvedSurfaceIsValidProfileCurve(Frame, Curve) Method |
Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidProfileCurve(
Frame frameOfReference,
Curve profileCurve
)
Public Shared Function IsValidProfileCurve (
frameOfReference As Frame,
profileCurve As Curve
) As Boolean
public:
static bool IsValidProfileCurve(
Frame^ frameOfReference,
Curve^ profileCurve
)
static member IsValidProfileCurve :
frameOfReference : Frame *
profileCurve : Curve -> bool
Parameters
- frameOfReference Frame
-
frameOfReference is an orthonormal frame that defines a local coordinate system for the surface of revolution.
- The frame can be "right-handed" or "left-handed".
- The origin of the frame is the base of point of the axis of revolution.
- The BasisZ of the frame is the direction of the axis.
- profileCurve Curve
-
The profile curve.
Return Value
Boolean
True if the profile curve is valid; False otherwise.
Exceptions
Remarks
The validity is defined as follows:
- The profile curve is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on the xz plane of the frame.
- It lies on the right side of the axis.
- Only the end points of the profile curve can touch the axis.
See Also