RevolvedSurfaceIsValidProfileCurve(XYZ, XYZ, Curve) Method |
Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidProfileCurve(
XYZ axisBasePoint,
XYZ axisDirection,
Curve profileCurve
)
Public Shared Function IsValidProfileCurve (
axisBasePoint As XYZ,
axisDirection As XYZ,
profileCurve As Curve
) As Boolean
public:
static bool IsValidProfileCurve(
XYZ^ axisBasePoint,
XYZ^ axisDirection,
Curve^ profileCurve
)
static member IsValidProfileCurve :
axisBasePoint : XYZ *
axisDirection : XYZ *
profileCurve : Curve -> bool
Parameters
- axisBasePoint XYZ
-
The base point of the axis of revolution.
- axisDirection XYZ
-
The direction of the axis.
- profileCurve Curve
-
The profile curve.
Return Value
Boolean
True if the profile curve is valid; False otherwise.
Exceptions
Remarks
The validity is defined as follows:
- The profile curve is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on only one side of the axis.
- Only the end points of the profile curve can touch the axis.
See Also