KeyBasedTreeEntriesLoadContent Class

This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalResourceLoadContent
    Autodesk.Revit.DBKeyBasedTreeEntriesLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntriesLoadContent : ExternalResourceLoadContent

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodAddEntry Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public methodBuildEntries Builds a KeyBasedTreeEntries object.
Public methodCanAddEntry Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public methodGetEntries Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public methodGetLoadResults Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public methodStatic memberIsEntriesBuilt Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public methodReset Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Top
Remarks

The class contains a KeyBasedTreeEntries object which should hold the KeyBasedTreeEntries data generated by the IExternalResourceServer.

An ExternalResourceServer can create the KeyBasedTreeEntries from an arbitrary data source by using AddEntry to add individual KeyBasedTreeEntries. Once all the desired entries have been added, BuildEntries can be called to construct the KeyBasedTreeEntries object from the individual entries that were added.

KeyBasedTreeEntriesLoadContent must have a built KeyBasedTreeEntries before its LoadStatus property can be set to ExternalResourceLoadStatus.Success.

See Also