ExternalResourceLoadContentLoadStatus Property |
A value to indicate the status of an external resource load operation. IExternalResourceServers
should set this in the LoadResource() method.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternalResourceLoadStatus LoadStatus { get; set; }
Public Property LoadStatus As ExternalResourceLoadStatus
Get
Set
public:
property ExternalResourceLoadStatus LoadStatus {
ExternalResourceLoadStatus get ();
void set (ExternalResourceLoadStatus value);
}
member LoadStatus : ExternalResourceLoadStatus with get, set
Property Value
ExternalResourceLoadStatus
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The ExternalResourceLoadContent does not contain all the necessary
data. To see the requirements for this particular resource type,
please see the documentation for the specific subclass of
ExternalResourceLoadContent.
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
See Also