KeyBasedTreeEntriesLoadContentAddEntry Method |
Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AddEntry(
KeyBasedTreeEntry entry
)
Public Function AddEntry (
entry As KeyBasedTreeEntry
) As Boolean
public:
bool AddEntry(
KeyBasedTreeEntry^ entry
)
member AddEntry :
entry : KeyBasedTreeEntry -> bool
Parameters
- entry KeyBasedTreeEntry
-
The entry to be added.
Return Value
Boolean
Returns true if an entry is added into the entry data set successfully,
returns false if an entry fails to be added because this entry is invalid or a duplicate
of one in the entry data set.
ExceptionsException | Condition |
---|
ArgumentException |
The KeyBasedTreeEntry object is not appropriate to be added in this KeyBasedTreeEntriesLoadContent.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already.
Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
|
Remarks
The entry will not be added if it is invalid or duplicate with the added entries.
See Also