KeyBasedTreeEntriesLoadContentBuildEntries Method |
Builds a KeyBasedTreeEntries object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void BuildEntries()
public:
void BuildEntries()
member BuildEntries : unit -> unit
ExceptionsException | Condition |
---|
InvalidOperationException |
The KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object is built already.
Adding more KeyBasedTreeEntries as well as repeated building, is not supported.
|
Remarks
This method will take all the entries that have been added, create a KeyBasedTreeEntries object out of these entries,
and also record possible errors that occurred while constructing this KeyBasedTreeEntries object.
After this function is called, no more entries can be added. And repeated calling of this function is not allowed either.
See Also