ConicalSurface Class

A Conical Surface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBConicalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConicalSurface : Surface

The ConicalSurface type exposes the following members.

Properties
 NameDescription
Public propertyAxis Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public propertyHalfAngle Cone angle.
Public propertyOrigin Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public propertyXDir X axis of the local coordinate system associated with this cone.
Public propertyYDir X axis of the local coordinate system associated with this cone.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates a conical surface defined by a local reference frame and a half angle.
Public methodGetFrameOfReference Returns frame of reference associated with this ConicalSurface.
Public methodStatic memberIsValidConeAngle Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Top
Remarks
The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.
See Also