ConicalSurface Class

A Conical Surface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSurface
    Autodesk.Revit.DBConicalSurface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConicalSurface : Surface

The ConicalSurface type exposes the following members.

Properties
 NameDescription
Public propertyAxis Axis of the cone. This is the Z axis of the local coordinate system associated with this cone.
Public propertyHalfAngle Cone angle.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Surface)
Public propertyOrientationMatchesParametricOrientation Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation.
(Inherited from Surface)
Public propertyOrigin Apex of the cone. This is the origin of the local coordinate system associated with this cone.
Public propertyXDir X axis of the local coordinate system associated with this cone.
Public propertyYDir X axis of the local coordinate system associated with this cone.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates a conical surface defined by a local reference frame and a half angle.
Public methodDispose
(Inherited from Surface)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundingBoxUV Gets the UV bounding box of the surface.
(Inherited from Surface)
Public methodGetFrameOfReference Returns frame of reference associated with this ConicalSurface.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStatic memberIsValidConeAngle Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Public methodProject Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.
(Inherited from Surface)
Public methodProjectWithGuessPoint Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
(Inherited from Surface)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The parametric equation of the cone is S(u, v) = center + v*[sin(halfAngle)(cos(u)*xVec + sin(u)*yVec) + cos(halfAngle)*zVec]. Only the branch of the cone with v >= 0 should be used.
See Also