ConicalSurfaceIsValidConeAngle Method |
Checks whether the input value lies is not 0, greater than -PI/2 and lesser than PI/2.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidConeAngle(
double halfAngle
)
Public Shared Function IsValidConeAngle (
halfAngle As Double
) As Boolean
public:
static bool IsValidConeAngle(
double halfAngle
)
static member IsValidConeAngle :
halfAngle : float -> bool
Parameters
- halfAngle Double
-
Cone half-angle parameter.
Return Value
Boolean
True if input is not 0, lesser than PI/2 and greater than -PI/2, false otherwise.
See Also