MessageBoxData Class

An object that represents a simple message box that prompts the user for some action.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.UI.EventsDialogBoxData
      Autodesk.Revit.UI.EventsMessageBoxData

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MessageBoxData : DialogBoxData

The MessageBoxData type exposes the following members.

Properties
 NameDescription
Public propertyDialogType An integer that describes the standard windows type of the dialog box.
Public propertyMessage The message that has been displayed in the dialog box.
Top
Methods
 NameDescription
Top
Remarks
When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
See Also