DialogBoxData Class

An object that is passed to your application when a dialog is displayed in Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.UI.EventsDialogBoxData
      Autodesk.Revit.UI.EventsMessageBoxData

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DialogBoxData : APIObject

The DialogBoxData type exposes the following members.

Properties
 NameDescription
Public propertyHelpId An ID that represents the dialog that has been displayed.
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodOverrideResult Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.
See Also