AdaptiveComponentInstanceUtils Class

An interface for Adaptive Component Instances.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAdaptiveComponentInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdaptiveComponentInstanceUtils

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberCreateAdaptiveComponentInstance Creates a FamilyInstance of Adaptive Component Family.
Public methodStatic memberGetInstancePlacementPointElementRefIds Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
Public methodStatic memberGetInstancePointElementRefIds Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
Public methodStatic memberGetInstanceShapeHandlePointElementRefIds Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Public methodStatic memberHasAdaptiveFamilySymbol Verifies if a FamilyInstance has an Adaptive Family Symbol.
Public methodStatic memberIsAdaptiveComponentInstance Verifies if a FamilyInstance is an Adaptive Component Instance.
Public methodStatic memberIsAdaptiveFamilySymbol Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
Public methodStatic memberIsInstanceFlipped Gets the value of the flip parameter on the adaptive instance.
Public methodStatic memberMoveAdaptiveComponentInstance Moves Adaptive Component Instance by the specified transformation.
Public methodStatic memberSetInstanceFlipped Sets the value of the flip parameter on the adaptive instance.
Top
Example
private void CreateAdaptiveComponentInstance(Document document, FamilySymbol symbol)
{
    // Create a new instance of an adaptive component family
    FamilyInstance instance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol);

    // Get the placement points of this instance
    IList<ElementId> placePointIds = new List<ElementId>();
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance);
    double x = 0;

    // Set the position of each placement point
    foreach (ElementId id in placePointIds)
    {
        ReferencePoint point = document.GetElement(id) as ReferencePoint;
        point.Position = new Autodesk.Revit.DB.XYZ(10*x, 10*Math.Cos(x), 0);
        x += Math.PI/6;
    }
}
See Also