AdaptiveComponentInstanceUtilsGetInstanceShapeHandlePointElementRefIds Method |
Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetInstanceShapeHandlePointElementRefIds(
FamilyInstance famInst
)
Public Shared Function GetInstanceShapeHandlePointElementRefIds (
famInst As FamilyInstance
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInstanceShapeHandlePointElementRefIds(
FamilyInstance^ famInst
)
static member GetInstanceShapeHandlePointElementRefIds :
famInst : FamilyInstance -> IList<ElementId>
Parameters
- famInst FamilyInstance
-
The FamilyInstance
Return Value
IListElementId
The Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Remarks
The output contains shape handle point ref ids.
If there are no shape handle points defined in the Family then the output
is empty.
See Also