AdaptiveComponentInstanceUtilsGetInstancePointElementRefIds Method |
Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetInstancePointElementRefIds(
FamilyInstance famInst
)
Public Shared Function GetInstancePointElementRefIds (
famInst As FamilyInstance
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetInstancePointElementRefIds(
FamilyInstance^ famInst
)
static member GetInstancePointElementRefIds :
famInst : FamilyInstance -> IList<ElementId>
Parameters
- famInst FamilyInstance
-
The FamilyInstance.
Return Value
IListElementId
The Adaptive Point Element Ref ids to which the instance geometry adapts.
Exceptions
Remarks
The output contains both placement point ref ids and the shape handles
point ref ids. The order corresponds to the same order as that
of the Adaptive Points in the Family (which may not be ordered as per
their placement number).
Will return an empty array if there are no placement points and shape
handles. To manipulate such an instance the following methods can be
useful:
1) RehostAdaptiveComponentInstanceWithNoPlacementPoints()
2) MoveAdaptiveComponentInstance()
See Also