AdaptiveComponentInstanceUtilsCreateAdaptiveComponentInstance Method |
Creates a FamilyInstance of Adaptive Component Family.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FamilyInstance CreateAdaptiveComponentInstance(
Document doc,
FamilySymbol famSymb
)
Public Shared Function CreateAdaptiveComponentInstance (
doc As Document,
famSymb As FamilySymbol
) As FamilyInstance
public:
static FamilyInstance^ CreateAdaptiveComponentInstance(
Document^ doc,
FamilySymbol^ famSymb
)
static member CreateAdaptiveComponentInstance :
doc : Document *
famSymb : FamilySymbol -> FamilyInstance
Parameters
- doc Document
-
The Document
- famSymb FamilySymbol
-
The FamilySymbol
Return Value
FamilyInstance
The Family Instance
Exceptions
Remarks
This method creates an Adaptive FamilyInstance and its PointElement references.
The references can be accessed by methods like GetInstancePointElementRefIds().
The PointElement references can be moved, rehosted or manipulated just like any
other PointElements. The FamilyInstance would then 'adapt' to these references.
See Also