AdaptiveComponentInstanceUtilsSetInstanceFlipped Method |
Sets the value of the flip parameter on the adaptive instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void SetInstanceFlipped(
FamilyInstance famInst,
bool flip
)
Public Shared Sub SetInstanceFlipped (
famInst As FamilyInstance,
flip As Boolean
)
public:
static void SetInstanceFlipped(
FamilyInstance^ famInst,
bool flip
)
static member SetInstanceFlipped :
famInst : FamilyInstance *
flip : bool -> unit
Parameters
- famInst FamilyInstance
-
The FamilyInstance
- flip Boolean
-
The flip flag
ExceptionsException | Condition |
---|
ArgumentException |
The FamilyInstance famInst is not an Adaptive Family Instance.
-or-
The FamilyInstance famInst does not have an Adaptive Family Symbol.
-or-
The FamilyInstance famInst cannot be flipped or unflipped.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
This operation failed.
|
See Also