FabricationServiceButton Class

The object contains information about a fabricaton button.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationServiceButton

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationServiceButton : IDisposable

The FabricationServiceButton type exposes the following members.

Properties
 NameDescription
Public propertyButtonIndex The button index for this button.
Public propertyCode The code of the button.
Public propertyConditionCount The number of conditions.
Public propertyIsAHanger Checks if the fabrication service button is hanger.
Public propertyIsStraight Checks if all of the fabrication service button conditions are straights.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the button.
Public propertyPaletteIndex The palette index for this button.
Public propertyServiceId The fabrication service identifier for the fabrication service this button belongs to.
Top
Methods
 NameDescription
Public methodContainsFabricationPartType Checks to see if the fabrication part type exists on one of the button conditions.
Public methodDisposeReleases all resources used by the FabricationServiceButton
Public methodGetConditionDescription Gets the description for the condition size range.
Public methodGetConditionImageGets the image for the specified fabrication service button condition.
Public methodGetConditionLowerValue Gets the condition lower value (valid if greater or equal) for a given condition index.
Public methodGetConditionName Gets the name of the specified condition on the fabrication service button.
Public methodGetConditionUpperValue Gets the condition upper value (valid if less) for a given condition index.
Public methodGetImageGets the image for fabrication service button.
Public methodIsExcluded Gets if the button's fabrication part content associated with the button is to be excluded from Route and Fill, Design to Fabrication, or Multi-Point Routing commands.
Public methodIsUnrestrictedCondition Checks if the condition is unrestricted.
Public methodIsValid Checks if the button contains only valid fittings.
Public methodStatic memberIsValidConditionIndex Validates if the given condition index is valid or not.
Top
Remarks
A fabrication service button defines what items to use for different conditions. Fabrication service buttons are part of a fabrication service.
See Also