AssetProperties Class

Represents a set of asset property(s).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualAssetProperty
    Autodesk.Revit.DB.VisualAssetProperties
      Autodesk.Revit.DB.VisualAsset

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetProperties : AssetProperty

The AssetProperties type exposes the following members.

Properties
 NameDescription
Public propertyItem 
Public propertySize The number of the AssetProperty(s) in the object.
Top
Methods
 NameDescription
Public methodFindByName Gets the property with the given name.
Public methodGet Gets the property at the given index.
Public methodIsValidIndex Returns true if the provided index is valid.
Top
See Also