AssetProperties Class

Represents a set of asset property(s).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualAssetProperty
    Autodesk.Revit.DB.VisualAssetProperties
      Autodesk.Revit.DB.VisualAsset

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetProperties : AssetProperty

The AssetProperties type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
(Inherited from AssetProperty)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AssetProperty)
Public propertyItem 
Public propertyNameGet the name of the AssetProperty
(Inherited from AssetProperty)
Public propertyNumberOfConnectedProperties The number of currently connected properties.
(Inherited from AssetProperty)
Public propertySize The number of the AssetProperty(s) in the object.
Public propertyTypeReturns the type of the AssetProperty
(Inherited from AssetProperty)
Top
Methods
 NameDescription
Public methodAddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
(Inherited from AssetProperty)
Public methodCode exampleAddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
(Inherited from AssetProperty)
Public methodDispose
(Inherited from AssetProperty)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodFindByName Gets the property with the given name.
Public methodGet Gets the property at the given index.
Public methodGetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
(Inherited from AssetProperty)
Public methodGetConnectedProperty Gets one connected property with specified index.
(Inherited from AssetProperty)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodCode exampleGetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
(Inherited from AssetProperty)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsEditable Check if property can be edited.
(Inherited from AssetProperty)
Public methodIsValidIndex Returns true if the provided index is valid.
Public methodIsValidSchemaIdentifier Check that schema name is valid
(Inherited from AssetProperty)
Public methodRemoveConnectedAsset Removes the connected asset attached to this asset property if any.
(Inherited from AssetProperty)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also