AssetPropertyIsEditable Method

Check if property can be edited.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsEditable()

Return Value

Boolean
True if property is editable.
Exceptions
ExceptionCondition
InvalidOperationException The asset property is not editable. Asset can be edited only in an edit scope.
Remarks
Properties can be edited only if there is an active Edit Scope and if the property is allowed to be changed.
See Also