RibbonItemData Class

Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      More

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonItemData : ItemData

The RibbonItemData type exposes the following members.

Properties
 NameDescription
Public propertyLongDescription Long description of the command tooltip
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
Top
Methods
 NameDescription
Public methodGetContextualHelpGets the contextual help bound with this control.
Public methodSetContextualHelpSets the contextual help bound with this button data.
Top
See Also
Inheritance Hierarchy