RibbonItemData Class

Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      More

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonItemData : ItemData

The RibbonItemData type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData)
Public propertyLongDescription Long description of the command tooltip
Public propertyName The internal name of the item.
(Inherited from ItemData)
Public propertyToolTip The tooltip of item.
(Inherited from ItemData)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ItemData)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetContextualHelpGets the contextual help bound with this control.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button data.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also
Inheritance Hierarchy