ComboBoxMemberData Class

This class contains information necessary to construct a ComboBoxMember.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UIComboBoxMemberData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ComboBoxMemberData : RibbonItemData

The ComboBoxMemberData type exposes the following members.

Constructors
 NameDescription
Public methodComboBoxMemberDataConstructs a new instance of ComboBoxMemberData.
Top
Properties
 NameDescription
Public propertyGroupNameGets or sets a group name for the ComboBoxMember.
Public propertyImageThe image shown on the ComboBoxMember.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData)
Public propertyLongDescription Long description of the command tooltip
(Inherited from RibbonItemData)
Public propertyName The internal name of the item.
(Inherited from ItemData)
Public propertyTextThe user-visible text of the ComboBoxMember.
Public propertyToolTip The tooltip of item.
(Inherited from ItemData)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
(Inherited from RibbonItemData)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ItemData)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetContextualHelpGets the contextual help bound with this control.
(Inherited from RibbonItemData)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button data.
(Inherited from RibbonItemData)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also