TextBoxData Class

This class contains information necessary to construct a text box in the Ribbon.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UITextBoxData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TextBoxData : RibbonItemData

The TextBoxData type exposes the following members.

Constructors
 NameDescription
Public methodTextBoxDataConstructs a new instance of TextBoxData.
Top
Properties
 NameDescription
Public propertyImageThe image of the TextBox.
Top
Methods
 NameDescription
Top
See Also