TextBoxData Class

This class contains information necessary to construct a text box in the Ribbon.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData
      Autodesk.Revit.UITextBoxData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TextBoxData : RibbonItemData

The TextBoxData type exposes the following members.

Constructors
 NameDescription
Public methodTextBoxDataConstructs a new instance of TextBoxData.
Top
Properties
 NameDescription
Public propertyImageThe image of the TextBox.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData)
Public propertyLongDescription Long description of the command tooltip
(Inherited from RibbonItemData)
Public propertyName The internal name of the item.
(Inherited from ItemData)
Public propertyToolTip The tooltip of item.
(Inherited from ItemData)
Public propertyToolTipImageThe image to show as a part of the button extended tooltip
(Inherited from RibbonItemData)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from ItemData)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetContextualHelpGets the contextual help bound with this control.
(Inherited from RibbonItemData)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetContextualHelpSets the contextual help bound with this button data.
(Inherited from RibbonItemData)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also