ItemData Class

Base class used to contain information necessary to construct RibbonItem and ContextMenuItem
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIItemData
    Autodesk.Revit.UIRibbonItemData

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ItemData : IDisposable

The ItemData type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The internal name of the item.
Public propertyToolTip The tooltip of item.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ItemData
Top
See Also