ButtonData Class

Base class used to contain information necessary to construct a button in the Ribbon.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ButtonData : RibbonItemData

The ButtonData type exposes the following members.

Properties
 NameDescription
Public propertyImageThe image of the button.
Public propertyLargeImageThe large image of the button.
Public propertyTextThe user-visible text of the button.
Top
Methods
 NameDescription
Top
See Also