AnalyticalPowerDistributableNodeData Class

Represents the data and parameters of a power distributable node. A power distribution node is an electrical analytical node with a distribution system which defines the connection rules between upstream and downstream electrical analytical nodes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalyticalPowerDistributableNodeData : AnalyticalDistributionNodePropertyData

The AnalyticalPowerDistributableNodeData type exposes the following members.

Properties
 NameDescription
Public propertyAssignedPhasesNumber The number of electrical phases assigned through the distribution system of the power distributable node.
Public propertyAssignedVoltage The voltage assigned through the distribution system of the power distributable node.
Public propertyConnectedPhases The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData)
Public propertyDistributionSystem The distribution system of the power distributable node.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData)
Public propertyNumberOfPhasesObsolete.
The number of electrical phases.
(Inherited from AnalyticalDistributionNodePropertyData)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from AnalyticalDistributionNodePropertyData)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAllAvailableConnectedPhasesOnDownstream Get all the available electrical connected phases that this power distributable node can provide to the downstream node.
Public methodGetApparentPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node.
Public methodGetConnectedPhasesOnDownstream Get the electrical connected phases of the downstream node.
Public methodGetDemandPerPhaseResults Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetConnectedPhasesOnDownstream Set the electrical connected phases of the downstream node.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also