AnalyticalPowerDistributableNodeDataDistributionSystem Property

The distribution system of the power distributable node.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId DistributionSystem { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The id isn't a distribution system id. -or- When setting this property: The distribution system id can't be set to the power distributable node.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
In the case of a transformer, it's crucial that the number of phases in the secondary distribution system matches that of the primary distribution system. If the number of phases in the primary system is set to be different from that of the secondary distribution system, it will result in a 'PrimaryNumOfPhasesNotEqualWithSecondary' error. If you anticipate this discrepancy, you can avoid the error by first setting the secondary distribution system to InvalidElementId, and then setting the primary distribution system.
See Also