AnalyticalPowerDistributableNodeDataGetAllAvailableConnectedPhasesOnDownstream Method |
Get all the available electrical connected phases that this power distributable node can provide to the downstream node.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElectricalConnectedPhases> GetAllAvailableConnectedPhasesOnDownstream(
ElementId id
)
Public Function GetAllAvailableConnectedPhasesOnDownstream (
id As ElementId
) As IList(Of ElectricalConnectedPhases)
public:
IList<ElectricalConnectedPhases>^ GetAllAvailableConnectedPhasesOnDownstream(
ElementId^ id
)
member GetAllAvailableConnectedPhasesOnDownstream :
id : ElementId -> IList<ElectricalConnectedPhases>
Parameters
- id ElementId
-
The downstream node id.
Return Value
IListElectricalConnectedPhases
All the available electrical connected phases that this power distributable node can provide to the downstream node.
Exceptions
Remarks
If node B supplies from node A, node B is the downstream node of node A, and node A is the upstream node of node B.
Usually one node may have many downstream nodes, but TransferSwitch can only have one downstream node.
See Also