AnalyticalDistributionNodePropertyDataNumberOfPhases Property |
Note: This API is now obsolete.
The number of electrical phases.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. For analytical power source, bus, transformer, transfer switch, the number of electrical phases is assigned through the distribution system of them, we suggest you use the 'AssignedPhasesNumber' property instead. For analytical equipment load, we suggest you use the 'PhasesNumber' property in 'AnalyticalEquipmentLoadData' class instead.")]
public int NumberOfPhases { get; }
<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. For analytical power source, bus, transformer, transfer switch, the number of electrical phases is assigned through the distribution system of them, we suggest you use the 'AssignedPhasesNumber' property instead. For analytical equipment load, we suggest you use the 'PhasesNumber' property in 'AnalyticalEquipmentLoadData' class instead.")>
Public ReadOnly Property NumberOfPhases As Integer
Get
public:
[ObsoleteAttribute(L"This property is deprecated in Revit 2025 and may be removed in a later version of Revit. For analytical power source, bus, transformer, transfer switch, the number of electrical phases is assigned through the distribution system of them, we suggest you use the 'AssignedPhasesNumber' property instead. For analytical equipment load, we suggest you use the 'PhasesNumber' property in 'AnalyticalEquipmentLoadData' class instead.")]
property int NumberOfPhases {
int get ();
}
[<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. For analytical power source, bus, transformer, transfer switch, the number of electrical phases is assigned through the distribution system of them, we suggest you use the 'AssignedPhasesNumber' property instead. For analytical equipment load, we suggest you use the 'PhasesNumber' property in 'AnalyticalEquipmentLoadData' class instead.")>]
member NumberOfPhases : int with get
Property Value
Int32
See Also